brcm2708: disable CONFIG_BCM2835_THERMAL by default
[oweals/openwrt.git] / target / linux / mvebu / Makefile
index 54bb15d68e5e63ab0382b6fdd26e23def2916df3..a07aa7cf2d24dd5648fa8599dacd4cae7a6fb685 100644 (file)
@@ -9,17 +9,17 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=mvebu
 BOARDNAME:=Marvell Armada 37x/38x/XP
-FEATURES:=usb pci pcie gpio nand squashfs
+FEATURES:=fpu usb pci pcie gpio nand squashfs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNEL_PATCHVER:=4.1
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))