brcm2708: disable CONFIG_BCM2835_THERMAL by default
[oweals/openwrt.git] / target / linux / mvebu / Makefile
index 1f7444d29b7ccff89f987da0a9fef11e2659524a..a07aa7cf2d24dd5648fa8599dacd4cae7a6fb685 100644 (file)
@@ -8,18 +8,18 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=mvebu
-BOARDNAME:=Marvell Armada XP/370
-FEATURES:=usb pci pcie gpio nand squashfs
+BOARDNAME:=Marvell Armada 37x/38x/XP
+FEATURES:=fpu usb pci pcie gpio nand squashfs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
 KERNELNAME:=zImage dtbs
 
-DEFAULT_PACKAGES += uboot-envtools
+DEFAULT_PACKAGES += uboot-envtools kmod-gpio-button-hotplug
 
 $(eval $(call BuildTarget))