ath79: phy-ar7200-usb: do not print error on defered init
[oweals/openwrt.git] / target / linux / mpc85xx / Makefile
index feaa3bc7317a04a11e439b46bf50af17b52e9f25..2ffdfeddcd98e1b905ae375ed59d5691168cc17b 100644 (file)
@@ -9,20 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+CPU_TYPE:=8540
+FEATURES:=squashfs ramdisk
+SUBTARGETS:=p1010 p1020 p2020
 
-LINUX_VERSION:=3.7.8
+KERNEL_PATCHVER:=5.4
+
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-booke-wdt
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2
 
 $(eval $(call BuildTarget))