ath79: phy-ar7200-usb: do not print error on defered init
[oweals/openwrt.git] / target / linux / mpc85xx / Makefile
index a83103d6acc36a4ba852f9d9ba9453b1a3b067e1..2ffdfeddcd98e1b905ae375ed59d5691168cc17b 100644 (file)
@@ -9,16 +9,18 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+CPU_TYPE:=8540
+FEATURES:=squashfs ramdisk
+SUBTARGETS:=p1010 p1020 p2020
 
-LINUX_VERSION:=2.6.38.6
+KERNEL_PATCHVER:=5.4
+
+KERNELNAME:=zImage
 
 include $(INCLUDE_DIR)/target.mk
 
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio swconfig kmod-ath9k wpad-basic kmod-usb2
 
 $(eval $(call BuildTarget))