lantiq: remove CPU_TYPE:=mips32r2, it gets overwritten anyway
[oweals/openwrt.git] / target / linux / mpc85xx / Makefile
index e43327acd82fcf5daf8cc735a4b64a46ed8da515..161c8cb8168fb25e4c98a6f280f57f6425ef99ab 100644 (file)
@@ -12,21 +12,23 @@ BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.4
 
-KERNEL_IMAGES := zImage cuImage.tl-wdr4900-v1
+define Target/Description
+       Build images for the Freescale MPC85xx based boards.
+endef
 
 include $(INCLUDE_DIR)/target.mk
 
+KERNEL_IMAGES := zImage
+ifeq ($(SUBTARGET),generic)
+KERNEL_IMAGES += cuImage.tl-wdr4900-v1
+endif
+
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))