lantiq: remove CPU_TYPE:=mips32r2, it gets overwritten anyway
[oweals/openwrt.git] / target / linux / mpc85xx / Makefile
index 5f3ad6c3d4968774229e51cdaab06805347189e5..161c8cb8168fb25e4c98a6f280f57f6425ef99ab 100644 (file)
@@ -12,9 +12,13 @@ BOARDNAME:=Freescale MPC85xx
 CPU_TYPE:=8540
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-SUBTARGETS=generic p1020
+SUBTARGETS:=generic p1020
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.4
+
+define Target/Description
+       Build images for the Freescale MPC85xx based boards.
+endef
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -25,11 +29,6 @@ endif
 
 DEFAULT_PACKAGES += \
        kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
-       kmod-leds-gpio kmod-booke-wdt \
-       swconfig kmod-ath9k wpad-mini
-
-define Target/Description
-       Build images for the Freescale MPC85xx based boards.
-endef
+       kmod-leds-gpio swconfig kmod-ath9k wpad-mini
 
 $(eval $(call BuildTarget))