ath79: Use -v1 suffix for TP-Link WDR3600/4300
[oweals/openwrt.git] / target / linux / mediatek / Makefile
index 0415d245eca11a9bcdffded732e9e3b9cb9e18db..0fda718714a506f3522c1bf07141ca2fa4ac7f77 100644 (file)
@@ -4,18 +4,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=mediatek
-BOARDNAME:=Mediatek Ralink ARM
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+BOARDNAME:=MediaTek Ralink ARM
+SUBTARGETS:=mt7622 mt7623
+FEATURES:=squashfs nand ramdisk fpu
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=4.4
-
-KERNELNAME:=Image dtbs zImage
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
-       kmod-mt76 kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
-       wpad-mini
+       kmod-mt76 kmod-leds-gpio kmod-gpio-button-hotplug \
+       wpad-basic
 
 $(eval $(call BuildTarget))