* remove obseleted m25p80 patch
[oweals/openwrt.git] / target / linux / lantiq / patches-3.0 / 450-mach-arv45xx.patch
index 05b28b798febf97c62b80b2922d1f3088bb86576..a05d1a519cc69d46f47aa04a9acd71701aae6843 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/lantiq/xway/Kconfig
 +++ b/arch/mips/lantiq/xway/Kconfig
-@@ -6,6 +6,10 @@
+@@ -6,6 +6,10 @@ config LANTIQ_MACH_EASY50712
        bool "Easy50712 - Danube"
        default y
  
  endif
 --- a/arch/mips/lantiq/xway/Makefile
 +++ b/arch/mips/lantiq/xway/Makefile
-@@ -5,3 +5,4 @@
+@@ -5,3 +5,4 @@ obj-$(CONFIG_SOC_AMAZON_SE) += clk-ase.o
  
  obj-$(CONFIG_LANTIQ_MACH_EASY50712) += mach-easy50712.o
  obj-$(CONFIG_LANTIQ_MACH_EASY50601) += mach-easy50601.o
 +obj-$(CONFIG_LANTIQ_MACH_ARV45XX) += mach-arv45xx.o
 --- /dev/null
 +++ b/arch/mips/lantiq/xway/mach-arv45xx.c
-@@ -0,0 +1,504 @@
+@@ -0,0 +1,495 @@
 +/*
 + *  This program is free software; you can redistribute it and/or modify it
 + *  under the terms of the GNU General Public License version 2 as published
@@ -50,7 +50,6 @@
 +#include "dev-leds-gpio.h"
 +#include "dev-dwc_otg.h"
 +
-+#ifdef CONFIG_MTD_PARTITIONS
 +static struct mtd_partition arv4510_partitions[] =
 +{
 +      {
 +      },
 +};
 +
-+#endif
-+
 +static struct physmap_flash_data arv4510_flash_data = {
-+#ifdef CONFIG_MTD_PARTITIONS
 +      .nr_parts       = ARRAY_SIZE(arv4510_partitions),
 +      .parts          = arv4510_partitions,
-+#endif
 +};
 +
 +static struct physmap_flash_data arv45xx_flash_data = {
-+#ifdef CONFIG_MTD_PARTITIONS
 +      .nr_parts       = ARRAY_SIZE(arv45xx_partitions),
 +      .parts          = arv45xx_partitions,
-+#endif
 +};
 +
 +static struct physmap_flash_data arv75xx_flash_data = {
-+#ifdef CONFIG_MTD_PARTITIONS
 +      .nr_parts       = ARRAY_SIZE(arv75xx_partitions),
 +      .parts          = arv75xx_partitions,
-+#endif
 +};
 +
 +static struct ltq_pci_data ltq_pci_data = {
 +                      arv752dpw22_init);
 --- a/arch/mips/lantiq/machtypes.h
 +++ b/arch/mips/lantiq/machtypes.h
-@@ -22,6 +22,17 @@
+@@ -22,6 +22,17 @@ enum lantiq_mach_type {
        LANTIQ_MACH_EASY98000NAND,      /* Falcon Eval Board, NAND Flash */
        LANTIQ_MACH_EASY98020,          /* Falcon Reference Board */
        LANTIQ_MACH_95C3AM1,            /* Board 95C3AM1 */