lantiq: cleanup the dsl control scripts
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index dfaccbb830925a029ec7e7947d88e03bb500d683..d7f75683e07ef4b5576db665a6cc422837dbd461 100644 (file)
@@ -6,20 +6,19 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
+FEATURES:=squashfs ubifs
+SUBTARGETS=xway xrx200 ase falcon
 
-LINUX_VERSION:=2.6.37.4
+LINUX_VERSION:=3.10.34
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-
-include $(INCLUDE_DIR)/target.mk
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))