generic: ar8216: fix unknown packet flooding for ar8229/ar8236
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index 8d845b95a78afbb8005829051bb2c8f886ef9245..b2b10c57bb56d0745e812f06b6ae2ec996e53660 100644 (file)
@@ -6,15 +6,13 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-LINUX_VERSION:=3.0.3
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=4.19
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Lantiq SoC