generic: ar8216: fix unknown packet flooding for ar8229/ar8236
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index 0f5064c3fc5f881549609f4e73a6eaf7b78a591e..b2b10c57bb56d0745e812f06b6ae2ec996e53660 100644 (file)
@@ -6,15 +6,13 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-#SUBTARGETS:=xway falcon ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-LINUX_VERSION:=2.6.39.2
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+KERNEL_PATCHVER:=4.19
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Lantiq SoC