lantiq: add ARV4525PW wifi led
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index c09be31a6eee0604741a5b927c856ad360335a07..af4295cbb836e5c64a0dd8c853a8f1163e986d96 100644 (file)
@@ -6,15 +6,15 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=xway falcon ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xrx200 xway xway_legacy
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.39.2
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC