kernel: backport support for accelerated SPI flash read
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index c8e376ccf494d9ee6ebb9cbcc12237b1cf249651..7b79b68c42daadd86457624220b3c39fdb28800a 100644 (file)
@@ -7,15 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs jffs2
-SUBTARGETS:=danube ar9 vr9 falcon svip_be
-LINUX_VERSION:=3.3.8
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-#SUBTARGETS=xway ase
-#LINUX_VERSION:=3.6.5
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC