kernel: backport support for accelerated SPI flash read
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index 94b506d4eec539e5bde5949fd50d9c5826df9fb1..7b79b68c42daadd86457624220b3c39fdb28800a 100644 (file)
@@ -7,13 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
+BOARDNAME:=Lantiq
 FEATURES:=squashfs
-SUBTARGETS=xway ase falcon
+SUBTARGETS=xway xrx200
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mno-branch-likely
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC