lantiq: fix dma locking problems with SMP
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index b0bed09dfd099d750ae704e7362ce911378842a0..66f3e7645d71e8d63b92abd17f62fb2d732bdd8a 100644 (file)
@@ -6,15 +6,15 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=3.1.10
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC