lantiq: fix dma locking problems with SMP
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index 29da8a3c682cf6b63561e5f125905ad1a118748f..66f3e7645d71e8d63b92abd17f62fb2d732bdd8a 100644 (file)
@@ -6,20 +6,20 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-LINUX_VERSION:=2.6.39.1
+KERNEL_PATCHVER:=4.4
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))