ramips: add a profile for AWM003
[oweals/openwrt.git] / target / linux / lantiq / Makefile
index 0f5064c3fc5f881549609f4e73a6eaf7b78a591e..143c11066418298f1d0d7cb60118b2375b010465 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-#SUBTARGETS:=xway falcon ase
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS=xway xrx200
 
-LINUX_VERSION:=2.6.39.2
+LINUX_VERSION:=3.10.49
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CPU_TYPE:=mips32r2
 
 define Target/Description
        Build firmware images for Lantiq SoC