ixp4xx/apex: Update to Apex 1.5.14, and add support for the Freecom FSG-3
[oweals/openwrt.git] / target / linux / ixp4xx / image / Makefile
index 70ff0ebf56a692ecf7fa6dda3ef093a62a8d02a1..e5368fbca4811b93f6d298e5d2653be56f286771 100644 (file)
@@ -7,43 +7,28 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-UCODEFILE:=IPL_ixp400NpeLibrary-2_4.zip
-
-ifneq ($(CONFIG_IXP4XX_INCLUDE_UCODE),)
-  define Require/npe-ucode
-       [ -f $(DL_DIR)/$(UCODEFILE) ]
-  endef
-  define Build/Compile/npe
-       $(MAKE) -C npe-ucode \
-               BUILD_DIR="$(KDIR)" \
-               TARGET="$(KDIR)" \
-               compile
-  endef
-  define Image/Build/slug
+define Image/Build/slug
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1).bin
+               -L $(KDIR)/apex-nslu2-armeb.bin \
+               -k $(BIN_DIR)/openwrt-nslu2-zImage \
+               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-nslu2-$(1).bin
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/slugimage.pl \
-               -F -L $(KDIR)/apex-nslu2-armeb.bin -m $(KDIR)/NPE-B \
-               -k $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-zImage \
-               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img \
-               -p -o $(BIN_DIR)/openwrt-nslu2-$(KERNEL)-$(1)-16mb.bin
-  endef
-endif
+               -F -L $(KDIR)/apex-nslu2-16mb-armeb.bin \
+               -k $(BIN_DIR)/openwrt-nslu2-zImage \
+               -r rootfs:$(BIN_DIR)/openwrt-$(BOARD)-$(1).img \
+               -p -o $(BIN_DIR)/openwrt-nslu2-$(1)-16mb.bin
+endef
 
 define Build/Compile
        $(MAKE) -C apex \
                BUILD_DIR="$(KDIR)" \
                TARGET="$(KDIR)" \
                compile 
-       $(call Build/Compile/npe)
 endef
 
 define Build/Clean
        $(MAKE) -C apex clean
-       $(MAKE) -C npe-ucode clean
 endef
 
 define Image/Prepare
@@ -51,8 +36,7 @@ define Image/Prepare
 endef
 
 define Image/BuildKernel
-       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-zImage
-#      $(shell BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh)
+       cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
        BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
 endef
 
@@ -61,25 +45,18 @@ define Image/Build
 endef
 
 define Image/Build/jffs2-64k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=65536 conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
 endef
 
 define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
        $(call Image/Build/slug,$(1))
 endef
 
 define Image/Build/squashfs
     $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img bs=131072 conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
        $(call Image/Build/slug,$(1))
 endef
 
 $(eval $(call BuildImage))
-
-$(eval $(call Require,npe-ucode, \
-       You must manually download $(UCODEFILE) from \\\
-       http://www.intel.com/design/network/products/npfamily/ixp400_archives.htm \\\
-       and put it in $(DL_DIR). \\\
-       You will need to agree to the Intel Public License to do so - please do read it! \
-))