ramips: revert faulty 4.4 config change from 9c242270907
[oweals/openwrt.git] / target / linux / ipq806x / patches-4.4 / 137-clk-qcom-Add-support-for-High-Frequency-PLLs-HFPLLs.patch
index a1b1f4b1f7930429343f78a31ce1246a00526341..7e964490e0c8f4c72a90fd873b4487dd4f3265c3 100644 (file)
@@ -28,7 +28,7 @@ I'd really like to get rid of __clk_hfpll_init_once() if possible...
 
 --- a/drivers/clk/qcom/Makefile
 +++ b/drivers/clk/qcom/Makefile
-@@ -8,6 +8,7 @@
+@@ -8,6 +8,7 @@ clk-qcom-y += clk-rcg2.o
  clk-qcom-y += clk-branch.o
  clk-qcom-y += clk-regmap-divider.o
  clk-qcom-y += clk-regmap-mux.o
@@ -86,7 +86,7 @@ I'd really like to get rid of __clk_hfpll_init_once() if possible...
 +              u32 regval = hd->user_val;
 +              unsigned long rate;
 +
-+              rate = clk_hw_get_rate(hw->clk);
++              rate = clk_hw_get_rate(hw);
 +
 +              /* Pick the right VCO. */
 +              if (hd->user_vco_mask && rate > hd->low_vco_max_rate)