treewide: convert WiFi caldata size and offset to hexadecimal
[oweals/openwrt.git] / target / linux / ipq806x / Makefile
index e65c24db512ec6beb8074abd76d0eba6acd7bb14..cd0e8b82ea31645a9dd1d3dcf4a61a807c0db543 100644 (file)
@@ -5,12 +5,12 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs nand fpu
+FEATURES:=squashfs nand fpu ramdisk
 CPU_TYPE:=cortex-a15
 CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=4.9
+KERNEL_PATCHVER:=4.14
 
 KERNELNAME:=zImage Image dtbs
 
@@ -20,7 +20,7 @@ DEFAULT_PACKAGES += \
        kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
        kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
        kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
-       kmod-ath10k wpad-mini \
+       kmod-ath10k-ct wpad-basic \
        uboot-envtools
 
 $(eval $(call BuildTarget))