treewide: convert WiFi caldata size and offset to hexadecimal
[oweals/openwrt.git] / target / linux / ipq806x / Makefile
index 36b32053bd1be2db6775f71728e5a3bb57965c8d..cd0e8b82ea31645a9dd1d3dcf4a61a807c0db543 100644 (file)
@@ -5,17 +5,22 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
-FEATURES:=squashfs
-CPU_TYPE:=cortex-a7
-MAINTAINER:=John Crispin <blogic@openwrt.org>
+FEATURES:=squashfs nand fpu ramdisk
+CPU_TYPE:=cortex-a15
+CPU_SUBTYPE:=neon-vfpv4
+MAINTAINER:=John Crispin <john@phrozen.org>
 
-KERNEL_PATCHVER:=3.18
+KERNEL_PATCHVER:=4.14
 
-KERNELNAME:=Image dtbs
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
-       kmod-leds-gpio kmod-gpio-button-hotplug kmod-qca-nss-gmac swconfig
-
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform \
+       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-ledtrig-usbport \
+       kmod-usb3 kmod-usb-dwc3-of-simple kmod-usb-phy-qcom-dwc3 \
+       kmod-ath10k-ct wpad-basic \
+       uboot-envtools
 
 $(eval $(call BuildTarget))