kernel: mips_disable_fpu: initialize fault_addr in fpu_emulator_cop1Handler
[oweals/openwrt.git] / target / linux / ipq806x / Makefile
index 7521e971ef0472c3e399c92176bb9419d066e190..b6ddfe26b9b8c167b32e35ca75c601fef1f8a4fd 100644 (file)
@@ -7,11 +7,16 @@ BOARD:=ipq806x
 BOARDNAME:=Qualcomm Atheros IPQ806X
 FEATURES:=squashfs
 CPU_TYPE:=cortex-a7
+MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.12
+KERNEL_PATCHVER:=3.18
 
-KERNELNAME="Image dtbs"
+KERNELNAME:=zImage Image dtbs
 
 include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += \
+       kmod-leds-gpio kmod-gpio-button-hotplug swconfig \
+       kmod-ata-core kmod-ata-ahci kmod-ata-ahci-platform
+
 
 $(eval $(call BuildTarget))