kernel: pick earlycon regression fixes from the stable-queue.git
[oweals/openwrt.git] / target / linux / generic / pending-3.18 / 201-extra_optimization.patch
index 7ec93a47f44e6562efd57c5f68bbc6432bde6c61..5a2396cfa377a83e287acf96e6434bd5c501df17 100644 (file)
@@ -1,7 +1,7 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -612,9 +612,9 @@ include $(srctree)/arch/$(SRCARCH)/Makef
- KBUILD_CFLAGS += $(call cc-option,-fno-delete-null-pointer-checks,)
+@@ -618,9 +618,9 @@ KBUILD_CFLAGS      += $(call cc-option,-fno-P
+ KBUILD_AFLAGS += $(call cc-option,-fno-PIE)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)