ar71xx: keep the RouterBOARD Power LED in On state
[oweals/openwrt.git] / target / linux / generic / patches-4.9 / 930-crashlog.patch
index 7877f5608cecad5e1cbbe45fc24a345d846647fc..e9041384355d7cf2739338f27e8c717a532b3717 100644 (file)
@@ -33,7 +33,7 @@
        depends on BROKEN || !FRV
 --- a/kernel/Makefile
 +++ b/kernel/Makefile
-@@ -112,6 +112,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
+@@ -113,6 +113,7 @@ obj-$(CONFIG_TORTURE_TEST) += torture.o
  obj-$(CONFIG_MEMBARRIER) += membarrier.o
  
  obj-$(CONFIG_HAS_IOMEM) += memremap.o
 +              crashlog_printf("Modules:");
 +              list_for_each_entry(m, crashlog_modules, list) {
 +                      crashlog_printf("\t%s@%p+%x", m->name,
-+                      m->module_core, m->core_size,
-+                      m->module_init, m->init_size);
++                      m->core_layout.base, m->core_layout.size,
++                      m->init_layout.base, m->init_layout.size);
 +              }
 +              crashlog_printf("\n");
 +              first = false;