kernel: add DT binding support to the jimage parser
[oweals/openwrt.git] / target / linux / generic / hack-4.9 / 202-reduce_module_size.patch
index 1ec8997fab12cf248f587bc62b73d5e606550578..f744b945fee13a8f4bc83babb91f2fc8188dc01f 100644 (file)
@@ -11,19 +11,14 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  Makefile | 2 +-
  1 file changed, 1 insertion(+), 1 deletion(-)
 
-diff --git a/Makefile b/Makefile
-index a40b373eba3a..984eb5907d00 100644
 --- a/Makefile
 +++ b/Makefile
-@@ -407,7 +407,7 @@ KBUILD_CFLAGS_KERNEL :=
- KBUILD_AFLAGS   := -D__ASSEMBLY__ $(call cc-option,-fno-PIE)
+@@ -403,7 +403,7 @@ KBUILD_AFLAGS_KERNEL :=
+ KBUILD_CFLAGS_KERNEL :=
  KBUILD_AFLAGS_MODULE  := -DMODULE
  KBUILD_CFLAGS_MODULE  := -DMODULE
 -KBUILD_LDFLAGS_MODULE := -T $(srctree)/scripts/module-common.lds
 +KBUILD_LDFLAGS_MODULE = -T $(srctree)/scripts/module-common.lds $(if $(CONFIG_PROFILING),,-s)
+ GCC_PLUGINS_CFLAGS :=
  
  # Read KERNELRELEASE from include/config/kernel.release (if it exists)
- KERNELRELEASE = $(shell cat include/config/kernel.release 2> /dev/null)
--- 
-2.11.0
-