octeon: add detection for edgerouter and edgerouter-pro
[oweals/openwrt.git] / target / linux / cns21xx / Makefile
index 96d90f370b89fc4c4258a0018d12d5c898bf7d58..4f320b2f29a04185944f2801bccbfefc2100d0aa 100644 (file)
@@ -10,9 +10,9 @@ ARCH:=arm
 BOARD:=cns21xx
 BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
-CFLAGS:=-Os -pipe -march=armv4 -mtune=fa526 -fno-caller-saves
+CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.7.7
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
@@ -24,4 +24,6 @@ define Target/Description
  Build firmware images for Cavium Networks CNS21XX based boards.
 endef
 
+KERNELNAME:="zImage uImage"
+
 $(eval $(call BuildTarget))