bcm63xx: drop linux 3.2 support
[oweals/openwrt.git] / target / linux / brcm63xx / modules.mk
index 2f09f48874da6eef179714c3e7c3094b0f6b6612..3dc205b26a6a8b7d9ba1a639af3c299d69f1b918 100644 (file)
@@ -10,13 +10,8 @@ define KernelPackage/bcm63xx-spi
   TITLE:=Broadcom BCM63xx SPI driver
   DEPENDS:=@TARGET_brcm63xx +kmod-spi-bitbang
   KCONFIG:=CONFIG_SPI_BCM63XX
-  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
-    FILES:=$(LINUX_DIR)/drivers/spi/spi-bcm63xx.ko
-    AUTOLOAD:=$(call AutoLoad,92,spi-bcm63xx)
-  else
-    FILES:=$(LINUX_DIR)/drivers/spi/bcm63xx_spi.ko
-    AUTOLOAD:=$(call AutoLoad,92,bcm63xx_spi)
-  endif
+  FILES:=$(LINUX_DIR)/drivers/spi/spi-bcm63xx.ko
+  AUTOLOAD:=$(call AutoLoad,92,spi-bcm63xx)
 endef
 
 define KernelPackage/bcm63xx-spi/description