bcm63xx: replace SPI driver with latest upstream version
[oweals/openwrt.git] / target / linux / brcm63xx / modules.mk
index e48d298bf0fc00d95aab8cceefd4a2809941d685..2f09f48874da6eef179714c3e7c3094b0f6b6612 100644 (file)
@@ -10,8 +10,13 @@ define KernelPackage/bcm63xx-spi
   TITLE:=Broadcom BCM63xx SPI driver
   DEPENDS:=@TARGET_brcm63xx +kmod-spi-bitbang
   KCONFIG:=CONFIG_SPI_BCM63XX
-  FILES:=$(LINUX_DIR)/drivers/spi/bcm63xx_spi.ko
-  AUTOLOAD:=$(call AutoLoad,92,bcm63xx_spi)
+  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+    FILES:=$(LINUX_DIR)/drivers/spi/spi-bcm63xx.ko
+    AUTOLOAD:=$(call AutoLoad,92,spi-bcm63xx)
+  else
+    FILES:=$(LINUX_DIR)/drivers/spi/bcm63xx_spi.ko
+    AUTOLOAD:=$(call AutoLoad,92,bcm63xx_spi)
+  endif
 endef
 
 define KernelPackage/bcm63xx-spi/description