brcm63xx: switch to 3.18
[oweals/openwrt.git] / target / linux / brcm63xx / Makefile
index 41a8219b0334d21c9b37b81265bd3a76174d7ae3..d46a21d72cd86453adc7b83382261af6d22a6f62 100644 (file)
@@ -9,13 +9,14 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
-FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=3.7.10
+SUBTARGETS:=generic smp
+FEATURES:=squashfs usb atm pci pcmcia usbgadget
+KERNEL_PATCHVER:=3.18
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += swconfig kmod-input-gpio-keys-polled kmod-button-hotplug
+DEFAULT_PACKAGES += swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers