fix board patches so that new boards are withing appropriate ifdef
[oweals/openwrt.git] / target / linux / brcm63xx / Makefile
index 9ba1157dbae18d195c26a676877b58b3495d86e6..098820f40582c5fb202954de53a9160dc9cb79fa 100644 (file)
@@ -10,11 +10,13 @@ ARCH:=mips
 BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 FEATURES:=squashfs jffs2 usb atm pci pcmcia
-LINUX_VERSION:=2.6.27.33
+LINUX_VERSION:=3.3.8
+MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += hostapd-mini kmod-switch gpioctl
+DEFAULT_PACKAGES += kmod-switch kmod-input-gpio-keys-polled \
+       kmod-button-hotplug
 
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers