add vlan definitions for Siemens SE505v2
[oweals/openwrt.git] / target / linux / brcm47xx / Makefile
index 5804ee9768c343beb9f4e800a9b25dff95914a47..ce5e8624c87f8cfc435ae847726f2b869466b26b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,19 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mipsel
 BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
-FEATURES:=squashfs usb
+FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=3.0.3
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Netgear WGT634U)
 endef
 
-# include the profiles
--include profiles/*.mk
-
 $(eval $(call BuildTarget))