Now we have b43 working in master mode, include b43 in the profile (#3827)
[oweals/openwrt.git] / target / linux / brcm47xx / Makefile
index 11485fe056e84f9532a73b7a317a31e1c33ce024..3ec9bbb83f64c0b82f2d7d4945a04d682c22bfe6 100644 (file)
@@ -11,17 +11,14 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.25.15
+
+include $(INCLUDE_DIR)/target.mk
+DEFAULT_PACKAGES += kmod-switch kmod-diag
 
 define Target/Description
        Build firmware images for Broadcom based routers
        (e.g. Netgear WGT634U)
 endef
 
-include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
-
-# include the profiles
--include profiles/*.mk
-
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))