bcm53xx: update Disable MMU and Dcache during decompression
[oweals/openwrt.git] / target / linux / brcm2708 / image / Makefile
index 00bee225550748da25b40c0696d45ea5f872c9c9..2afd29b592dce887cc5ab31c548a587bccc371ca 100644 (file)
@@ -11,6 +11,16 @@ include $(INCLUDE_DIR)/host.mk
 FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_BRCM2708_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
+ifneq ($(CONFIG_TARGET_IMAGES_GZIP),)
+  define Image/gzip
+    gzip -9n -c $(1) > $(1).gz
+    mv $(1).gz $(BIN_DIR)
+  endef
+else
+  define Image/gzip
+  endef
+endif
+
 ### Image scripts ###
 define Build/build-dtb
        $(LINUX_DIR)/scripts/dtc/dtc -O dtb -o $@.dtb $(DTS_DIR)/$(DEVICE_DTS).dts
@@ -40,6 +50,7 @@ endef
 define Build/sdcard-img
        ./gen_rpi_sdcard_img.sh $@ $@.boot $(word 2,$^) \
                $(CONFIG_BRCM2708_SD_BOOT_PARTSIZE) $(CONFIG_TARGET_ROOTFS_PARTSIZE)
+       $(call Image/gzip,$@)
 endef
 
 ### Device macros ###
@@ -73,6 +84,8 @@ ifeq ($(SUBTARGET),bcm2708)
   $(eval $(call add_bcm2708,RaspberryPi_B,rpi-b,bcm2708-rpi-b))
   # Raspberry Pi Model B+
   $(eval $(call add_bcm2708,RaspberryPi_BPlus,rpi-b-plus,bcm2708-rpi-b-plus))
+  # Raspberry Pi Compute Module
+  $(eval $(call add_bcm2708,RaspberryPi_CM,rpi-cm,bcm2708-rpi-cm))
 endif
 
 ### BCM2709/BCM2836 ###