ath79: add support for kernel 5.4
[oweals/openwrt.git] / target / linux / ath79 / patches-5.4 / 404-mtd-cybertan-trx-parser.patch
diff --git a/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch b/target/linux/ath79/patches-5.4/404-mtd-cybertan-trx-parser.patch
new file mode 100644 (file)
index 0000000..c26ef60
--- /dev/null
@@ -0,0 +1,24 @@
+--- a/drivers/mtd/parsers/Makefile
++++ b/drivers/mtd/parsers/Makefile
+@@ -1,3 +1,4 @@
++obj-$(CONFIG_MTD_PARSER_CYBERTAN)     += parser_cybertan.o
+ # SPDX-License-Identifier: GPL-2.0-only
+ obj-$(CONFIG_MTD_AR7_PARTS)           += ar7part.o
+ obj-$(CONFIG_MTD_BCM47XX_PARTS)               += bcm47xxpart.o
+--- a/drivers/mtd/parsers/Kconfig
++++ b/drivers/mtd/parsers/Kconfig
+@@ -94,6 +94,14 @@ config MTD_AFS_PARTS
+         for your particular device. It won't happen automatically. The
+         'physmap' map driver (CONFIG_MTD_PHYSMAP) does this, for example.
++config MTD_PARSER_CYBERTAN
++      tristate "Parser for Cybertan format partitions"
++      depends on MTD && (ATH79 || COMPILE_TEST)
++      help
++        Cybertan has a proprietory header than encompasses a Broadcom trx
++        header. This driver will parse the header and take care of the
++        special offsets that result in the extra headers.
++
+ config MTD_PARSER_TRX
+       tristate "Parser for TRX format partitions"
+       depends on MTD && (BCM47XX || ARCH_BCM_5301X || COMPILE_TEST)