ath79: initial gl-ar300m support
[oweals/openwrt.git] / target / linux / ath79 / image / generic-ubnt.mk
index 1aae93869e27df274ab3478dd1dab7625b3c43f0..900167f6269cbb2c349b7faeca075df6870ee670 100644 (file)
@@ -79,3 +79,22 @@ define Device/ubnt_unifi
   SUPPORTED_DEVICES += unifi
 endef
 TARGET_DEVICES += ubnt_unifi
+
+define Device/ubnt-unifiac
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2
+  DEVICE_PROFILE := UBNT
+  IMAGE_SIZE := 7744k
+  IMAGES := sysupgrade.bin
+  IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | append-rootfs | pad-rootfs | check-size $$$$(IMAGE_SIZE)
+endef
+
+
+define Device/ubnt-unifiac-lite
+  $(Device/ubnt-unifiac)
+  DEVICE_TITLE := Ubiquiti UniFi AC-Lite
+  DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
+  DEVICE_PROFILE += UBNTUNIFIACLITE
+  BOARDNAME := UBNT-UF-AC-LITE
+  ATH_SOC := qca9563
+endef
+TARGET_DEVICES += ubnt-unifiac-lite