ath79: ubnt-xm: support ath9k firmware loading
[oweals/openwrt.git] / target / linux / ath79 / image / generic-tp-link.mk
index 623252ee7d0d90cc8c9ec061758d510a920fa2b0..926c3cb6181c7956536e6f515f51a20d2a10de5f 100644 (file)
@@ -1,5 +1,14 @@
 include ./common-tp-link.mk
 
+define Device/tplink_archer-c7-v1
+  $(Device/tplink-8mlzma)
+  ATH_SOC := qca9558
+  DEVICE_TITLE := TP-LINK Archer C7 v1
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport kmod-ath10k ath10k-firmware-qca988x
+  TPLINK_HWID := 0x75000001
+endef
+TARGET_DEVICES += tplink_archer-c7-v1
+
 define Device/tplink_archer-c7-v2
   $(Device/tplink-16mlzma)
   ATH_SOC := qca9558
@@ -12,7 +21,7 @@ define Device/tplink_archer-c7-v2
 endef
 TARGET_DEVICES += tplink_archer-c7-v2
 
-define Device/tplink_tl-re450-v2
+define Device/tplink_re450-v2
   $(Device/tplink)
   ATH_SOC := qca9563
   IMAGE_SIZE := 6016k
@@ -27,7 +36,7 @@ define Device/tplink_tl-re450-v2
     append-metadata | check-size $$$$(IMAGE_SIZE)
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
 endef
-TARGET_DEVICES += tplink_tl-re450-v2
+TARGET_DEVICES += tplink_re450-v2
 
 define Device/tplink_tl-wdr3600
   $(Device/tplink-8mlzma)
@@ -49,6 +58,15 @@ define Device/tplink_tl-wdr4300
 endef
 TARGET_DEVICES += tplink_tl-wdr4300
 
+define Device/tplink_tl-wdr4900-v2
+  $(Device/tplink-8mlzma)
+  ATH_SOC := qca9558
+  DEVICE_TITLE := TP-LINK TL-WDR4900 v2
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+  TPLINK_HWID := 0x49000002
+endef
+TARGET_DEVICES += tplink_tl-wdr4900-v2
+
 define Device/tplink_tl-wr1043nd-v1
   $(Device/tplink-8m)
   ATH_SOC := ar9132