ath79: add TP-Link TL-WR703N port
[oweals/openwrt.git] / target / linux / at91 / Makefile
index dfa3bfbb65417605c60e9ca3958c0ffe36493fe4..d71e0850ff19f19ce9874222a4311dfaa03798ee 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,17 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=at91
-BOARDNAME:=AT91
-FEATURES:=squashfs usb
+MAINTAINER:=Claudio Mignanti <c.mignanti@gmail.com>
+BOARDNAME:=Microchip (Atmel AT91)
+FEATURES:=ext4 squashfs targz usb usbgadget ubifs
+SUBTARGETS:=sama5d2 sama5d3 sama5d4 legacy
 
-#LINUX_VERSION:=2.6.21.5
-LINUX_VERSION:=2.6.22.4
+KERNEL_PATCHVER:=4.9
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage dtbs
 
-define Target/Description
-  Build fimware images for Figment Design Labs VersaLink board.
-endef
+DEFAULT_PACKAGES += kmod-usb-ohci kmod-at91-udc kmod-usb-gadget-eth
 
 $(eval $(call BuildTarget))