kernel: update m25p80 in 4.1 to the latest version from 4.4-rc1
[oweals/openwrt.git] / target / linux / ar71xx / patches-4.1 / 816-MIPS-ath79-add-tl-wdr3320-v2-support.patch
index aa78d599d51f6d59455686ad85642fa187f65d23..3e583bfee04d2c0d77b7baab77d207217e1a66f5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1065,6 +1065,17 @@ config ATH79_MACH_TL_WA901ND_V2
+@@ -1074,6 +1074,17 @@ config ATH79_MACH_TL_WA901ND_V2
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
@@ -20,7 +20,7 @@
        select SOC_AR934X
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -156,6 +156,7 @@ enum ath79_mach_type {
+@@ -158,6 +158,7 @@ enum ath79_mach_type {
        ATH79_MACH_TL_WA901ND,          /* TP-LINK TL-WA901ND */
        ATH79_MACH_TL_WA901ND_V2,       /* TP-LINK TL-WA901ND v2 */
        ATH79_MACH_TL_WA901ND_V3,       /* TP-LINK TL-WA901ND v3 */
@@ -30,7 +30,7 @@
        ATH79_MACH_TL_WDR6500_V2,       /* TP-LINK TL-WDR6500 v2 */
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -132,6 +132,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WA7210N_V2)     +
+@@ -133,6 +133,7 @@ obj-$(CONFIG_ATH79_MACH_TL_WA7210N_V2)     +
  obj-$(CONFIG_ATH79_MACH_TL_WA830RE_V2)        += mach-tl-wa830re-v2.o
  obj-$(CONFIG_ATH79_MACH_TL_WA901ND)   += mach-tl-wa901nd.o
  obj-$(CONFIG_ATH79_MACH_TL_WA901ND_V2)        += mach-tl-wa901nd-v2.o