ar71xx: add profile and build image for dir-825-c1
[oweals/openwrt.git] / target / linux / ar71xx / generic / profiles / d-link.mk
index 3068c4f31ac6441ebbe1c29e73d1b2e6e745d8e8..37aaedd932aadb6c85bfad0deabb9419f9636093 100644 (file)
@@ -16,6 +16,16 @@ endef
 
 $(eval $(call Profile,DIR600A1))
 
+define Profile/DIR601A1
+       NAME:=D-Link DIR-601 rev. A1
+       PACKAGES:=
+endef
+
+define Profile/DIR601A1/Description
+       Package set optimized for the D-Link DIR-601 rev. A1.
+endef
+
+$(eval $(call Profile,DIR601A1))
 
 define Profile/DIR615C1
        NAME:=D-Link DIR-615 rev. C1
@@ -51,3 +61,14 @@ define Profile/DIR825B1/Description
 endef
 
 $(eval $(call Profile,DIR825B1))
+
+define Profile/DIR825C1
+       NAME:=D-Link DIR-825 rev. C1
+       PACKAGES:=kmod-usb-core mod-usb2 kmod-ledtrig-usbdev
+endef
+
+define Profile/DIR825C1/Description
+       Package set optimized for the D-Link DIR-825 rev. C1.
+endef
+
+$(eval $(call Profile,DIR825C1))