bcm53xx: build images for Luxul ABR-4500 and XBR-4500 routers
[oweals/openwrt.git] / target / linux / ar71xx / Makefile
index b2a16f91258f396a2f05b7edd4802fbabe96c309..aa53b497355a2220c938db2abb535c13fca32793 100644 (file)
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
-FEATURES:=mips16
-CPU_TYPE=34kc
-SUBTARGETS:=generic nand mikrotik
+FEATURES:=usbgadget source-only
+CPU_TYPE:=24kc
+SUBTARGETS:=generic tiny nand mikrotik
 
-LINUX_VERSION:=3.10.44
+KERNEL_PATCHVER:=4.14
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-gpio-button-hotplug swconfig \
-       kmod-ath9k wpad-mini uboot-envtools
+       kmod-ath9k uboot-envtools
 
 $(eval $(call BuildTarget))