ar71xx: clean up profiles, put in kmod-ath9k and wpad-mini by default (fixes #9954)
[oweals/openwrt.git] / target / linux / ar71xx / Makefile
index b223c40dd8863595997ac82f6806c7d716ad9428..6b8dd8011393bf8b5f59a35fb3e531eecde8fc48 100644 (file)
@@ -13,13 +13,14 @@ FEATURES:=squashfs jffs2 targz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 SUBTARGETS:=generic nand
 
-LINUX_VERSION:=2.6.37.6
+LINUX_VERSION:=2.6.39.4
 
 include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig
+       kmod-input-gpio-keys-polled kmod-button-hotplug swconfig \
+       kmod-ath9k wpad-mini
 
 define Target/Description
        Build firmware images for Atheros AR71xx/AR913x/AR934x based boards.