ar71xx: cr5000: board data: Use better macro name
[oweals/openwrt.git] / target / linux / apm821xx / sata / target.mk
index 60efb508d4bc0300bb4fb130174fa79dc4c6c98a..a5107f1067aa560bd75a1b64c42902180ae884a2 100644 (file)
@@ -1,13 +1,9 @@
 BOARDNAME := Devices which boot from SATA (NAS)
-FEATURES += ext4 usb
+FEATURES += ext4 usb ramdisk squashfs
 DEFAULT_PACKAGES += badblocks block-mount e2fsprogs \
-                   kmod-dm kmod-md-mod partx-utils
+                   kmod-dm kmod-md-mod partx-utils mkf2fs f2fsck
 
 define Target/Description
        Build firmware images for APM82181 boards that boot from SATA.
        For NAS like the MyBook Live Series.
 endef
-
-$(eval $(call $(if $(CONFIG_TARGET_ROOTFS_EXT4FS),RequireCommand,Ignore),genext2fs, \
-        Please install genext2fs. \
-))