apm821xx: add DEVICE_DTS_DIR variable, remove redundant DEVICE_VARS entry
[oweals/openwrt.git] / target / linux / apm821xx / image / Makefile
index 08173c603fdb0c0fc0e44fac9423ae1c81127ff4..94fcd58fb3780b8f0a388c17397746a673d4ac69 100644 (file)
@@ -6,14 +6,16 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 include $(INCLUDE_DIR)/host.mk
 
-DEVICE_VARS += DEVICE_DTS DEVICE_PROFILE IMAGE_SIZE DTB_SIZE
+DEVICE_VARS += DEVICE_PROFILE IMAGE_SIZE DTB_SIZE
 
 define Device/Default
+  PROFILES := Default
   KERNEL_DEPENDS = $$(wildcard ../dts/$$(DEVICE_DTS).dts)
   DEVICE_PROFILE :=
   DEVICE_DTS :=
   KERNEL_ENTRY := 0x00000000
   KERNEL_LOADADDR := 0x00000000
+  DEVICE_DTS_DIR := ../dts
 endef
 
 define Build/dtb