This patch allows the user to specify esfq as the leaf qdisc, as well as perturb...
[oweals/openwrt.git] / rules.mk
index 3473b212de4b6b4c1e054e435517c50b88117694..47db7f62d2b1d4c7927b1ff0d73fd20fce307b12 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -80,7 +80,6 @@ STAMP_DIR_HOST=$(BUILD_DIR_HOST)/stamp
 TARGET_ROOTFS_DIR?=$(if $(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(call qstrip,$(CONFIG_TARGET_ROOTFS_DIR)),$(BUILD_DIR))
 TARGET_DIR:=$(TARGET_ROOTFS_DIR)/root-$(BOARD)
 STAGING_DIR_ROOT:=$(STAGING_DIR)/root-$(BOARD)
-DEBUG_DIR:=$(BUILD_DIR)/debug-$(BOARD)
 BUILD_LOG_DIR:=$(TOPDIR)/logs
 
 TARGET_PATH:=$(STAGING_DIR_HOST)/bin:$(PATH)
@@ -220,6 +219,10 @@ $(call shvar,$(1))=$$(call $(1))
 export $(call shvar,$(1))
 endef
 
+define include_mk
+$(eval -include $(if $(DUMP),,$(STAGING_DIR)/mk/$(strip $(1))))
+endef
+
 # file extension
 ext=$(word $(words $(subst ., ,$(1))),$(subst ., ,$(1)))