tools: tplink-safeloader: add C7v5 EU SupportList
[oweals/openwrt.git] / package / system / fstools / Makefile
index 759ea65978f69db3f7e87ab425873a5eb097163e..3f8fbd99f4b081dfa77d00692cee24fd8eb20e74 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=fstools
-PKG_RELEASE:=1
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL=$(LEDE_GIT)/project/fstools.git
-PKG_SOURCE_DATE:=2017-03-29
-PKG_SOURCE_VERSION:=20c16fc5fec00fdae547f083a822a7f1bd67d143
-PKG_MIRROR_HASH:=fc6402291119744843b8482d3f02d5e819b92afe52f261fa30ed8bd26f4a62f1
+PKG_SOURCE_URL=$(PROJECT_GIT)/project/fstools.git
+PKG_SOURCE_DATE:=2018-09-29
+PKG_SOURCE_VERSION:=29e53af0b91954ca6a13bdd1f0e67c939ccb8e6d
+PKG_MIRROR_HASH:=e90c60362dc3f304c9748b57a3e602f37fd758bf8134fbc3fbbda4300d4f46c7
 CMAKE_INSTALL:=1
 
 PKG_LICENSE:=GPL-2.0
@@ -33,6 +33,8 @@ include $(INCLUDE_DIR)/cmake.mk
 
 TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lrt)
 CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_UBIFS_EXTROOT),-DCMAKE_UBIFS_EXTROOT=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME),-DCMAKE_OVL_MOUNT_FULL_ACCESS_TIME=y)
+CMAKE_OPTIONS += $(if $(CONFIG_FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB),-DCMAKE_OVL_MOUNT_COMPRESS_ZLIB=y)
 
 define Package/fstools
   SECTION:=base
@@ -50,6 +52,20 @@ define Package/fstools/config
                default y
                help
                        This option makes it possible to use extroot functionality if the root filesystem resides on an UBIFS partition
+
+       config FSTOOLS_OVL_MOUNT_FULL_ACCESS_TIME
+               depends on PACKAGE_fstools
+               bool "Full access time accounting"
+               default n
+               help
+                       This option enables the full access time accounting (warning: it will increase the flash writes).
+
+       config FSTOOLS_OVL_MOUNT_COMPRESS_ZLIB
+               depends on PACKAGE_fstools
+               bool "Compress using zlib"
+               default n
+               help
+                       This option enables the compression using zlib on the storage device.
 endef
 
 define Package/snapshot-tool
@@ -92,8 +108,8 @@ define Package/block-mount/install
        $(INSTALL_DIR) $(1)/sbin $(1)/lib $(1)/usr/sbin $(1)/etc/hotplug.d/block $(1)/etc/init.d/ $(1)/etc/uci-defaults/
 
        $(INSTALL_BIN) ./files/fstab.init $(1)/etc/init.d/fstab
-       $(INSTALL_DATA) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
-       $(INSTALL_DATA) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
+       $(INSTALL_CONF) ./files/fstab.default $(1)/etc/uci-defaults/10-fstab
+       $(INSTALL_CONF) ./files/mount.hotplug $(1)/etc/hotplug.d/block/10-mount
 
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/sbin/block $(1)/sbin/
        $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/lib/libblkid-tiny.so $(1)/lib/