add new ar7 dsl driver (thanks, matteo), mark ar7-2.4 as broken and enable ar7-2.6
[oweals/openwrt.git] / package / shfs / Makefile
index ae99df39269a3ff325b2d4c412d3670a8ac97d8f..0023c009b07dea5afcb51b7efcd2eb9fd3163b91 100644 (file)
@@ -16,10 +16,6 @@ PKG_RELEASE:=2
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SF/shfs
 PKG_MD5SUM:=016f49d71bc32eee2b5d11fc1600cfbe
-PKG_CAT:=zcat
-
-PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
-PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -41,7 +37,7 @@ define KernelPackage/shfs
        \\\
        This package contains the ShFS kernel module.
   FILES:=$(PKG_INSTALL_DIR)/lib/modules/$(LINUX_VERSION)/kernel/fs/shfs/shfs.$(LINUX_KMOD_SUFFIX)
-  SUBMENU:=Network Support
+  SUBMENU:=Filesystems
   VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
   AUTOLOAD:=$(call AutoLoad,40,shfs)
 endef