dante: update to 1.4.1
[oweals/openwrt.git] / package / network / utils / dante / Makefile
index 90768ad474640faa826802223b536fefa1b9e3c1..b49ae7291c43a9b869ceecbc84830c9acf3837a8 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dante
-PKG_VERSION:=1.2.2
+PKG_VERSION:=1.4.1
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -16,18 +16,23 @@ PKG_SOURCE_URL:=http://www.inet.no/dante/files/
 PKG_MD5SUM:=69b9d6234154d7d6a91fcbd98c68e62a
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_LICENSE:=BSD-4-Clause
 
 PKG_FIXUP:=autoreconf
 PKG_INSTALL:=1
 
 include $(INCLUDE_DIR)/package.mk
 
-TARGET_CFLAGS += -D_GNU_SOURCE
+TARGET_CFLAGS += -D_GNU_SOURCE -std=gnu89
+
 CONFIGURE_ARGS += \
        --without-upnp \
        --without-pam \
        --disable-libwrap
 
+CONFIGURE_VARS += \
+       ac_cv_search_pam_start=""
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/