treewide: clean up download hashes
[oweals/openwrt.git] / package / network / services / lldpd / Makefile
index 5a1921e9d0b6b5432b42da705ca396f1182abbf3..3579e53e029583f07e3201faabff27339884bf3d 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=lldpd
-PKG_VERSION:=0.7.13
-PKG_RELEASE:=2
+PKG_VERSION:=0.9.5
+PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://media.luffy.cx/files/lldpd
-PKG_MD5SUM:=13e8be761753eac9a8e12128acba40b4
+PKG_HASH:=e9585c52f14808f03f6b6c3a9163c95b542a47b18abe002992b155d143a1a247
 
-PKG_MAINTAINER:=Jo-Philipp Wich <jow@openwrt.org>
+PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=ISC
 
 PKG_FIXUP:=autoreconf
@@ -31,7 +31,7 @@ define Package/lldpd
   SUBMENU:=Routing and Redirection
   TITLE:=Link Layer Discovery Protocol daemon
   URL:=https://github.com/vincentbernat/lldpd/wiki
-  DEPENDS:=+libevent2 +USE_EGLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
+  DEPENDS:=+libevent2 +USE_GLIBC:libbsd +LLDPD_WITH_JSON:libjson-c
   USERID:=lldp=121:lldp=129
   MENU:=1
 endef
@@ -49,6 +49,14 @@ define Package/lldpd/description
        Link-Layer notifications to adjacent network devices.
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/liblldpctl.so* $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldpctl.h $(1)/usr/include/lldpctl.h
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/lldp-const.h $(1)/usr/include/lldp-const.h
+endef
+
 define Package/lldpd/install
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/lldpd.d
@@ -77,16 +85,25 @@ define Package/lldpd/conffiles
 endef
 
 CONFIGURE_ARGS += \
+       $(if $(CONFIG_LLDPD_WITH_PRIVSEP), \
        --with-privsep-user=lldp \
        --with-privsep-group=lldp \
        --with-privsep-chroot=/var/run/lldp \
+       ,--disable-privsep) \
        --with-readline=no \
        --with-embedded-libevent=no \
+       --disable-hardening \
+       --without-xml \
+       --sysconfdir=/tmp \
        $(if $(CONFIG_LLDPD_WITH_CDP),,--disable-cdp) \
        $(if $(CONFIG_LLDPD_WITH_FDP),,--disable-fdp) \
        $(if $(CONFIG_LLDPD_WITH_EDP),,--disable-edp) \
+       $(if $(CONFIG_LLDPD_WITH_LLDPMED),,--disable-lldpmed) \
+       $(if $(CONFIG_LLDPD_WITH_DOT1),,--disable-dot1) \
+       $(if $(CONFIG_LLDPD_WITH_DOT3),,--disable-dot3) \
+       $(if $(CONFIG_LLDPD_WITH_CUSTOM),,--disable-custom) \
        $(if $(CONFIG_LLDPD_WITH_SONMP),,--disable-sonmp) \
-       $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c)
+       $(if $(CONFIG_LLDPD_WITH_JSON),--with-json=json-c,--with-json=no)
 
 
 $(eval $(call BuildPackage,lldpd))