mac80211: limit TID buffering to prevent out-of-memory issues on low-memory systems
[oweals/openwrt.git] / package / mac80211 / patches / 002-disable_rfkill.patch
index 887b9956f83efff206662f3afef0b7f6b7761e1b..94249413ba78c68755e324161a6932d5f3e92d92 100644 (file)
@@ -1,6 +1,6 @@
 --- a/config.mk
 +++ b/config.mk
-@@ -87,7 +87,7 @@ endif # build check
+@@ -83,7 +83,7 @@ endif # build check
  endif # kernel Makefile check
  
  # These both are needed by compat-wireless || compat-bluetooth so enable them
@@ -9,7 +9,7 @@
  
  ifeq ($(CONFIG_MAC80211),y)
  $(error "ERROR: you have MAC80211 compiled into the kernel, CONFIG_MAC80211=y, as such you cannot replace its mac80211 driver. You need this set to CONFIG_MAC80211=m. If you are using Fedora upgrade your kernel as later version should this set as modular. For further information on Fedora see https://bugzilla.redhat.com/show_bug.cgi?id=470143. If you are using your own kernel recompile it and make mac80211 modular")
-@@ -649,10 +649,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
+@@ -674,10 +674,10 @@ endif #CONFIG_COMPAT_KERNEL_2_6_27
  # We need the backported rfkill module on kernel < 2.6.31.
  # In more recent kernel versions use the in kernel rfkill module.
  ifdef CONFIG_COMPAT_KERNEL_2_6_31