fix a compile error
[oweals/openwrt.git] / package / keynote / Makefile
index ed4d4f020b8d384dab4ea5a27586f9520a24b62d..47469b61c3490e0e1f58ef02bf3d973235964eba 100644 (file)
@@ -4,9 +4,10 @@
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
-# $Id: Makefile 4619 2006-08-22 09:50:02Z florian $
+# $Id$
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=keynote
 PKG_VERSION:=2.3
@@ -15,12 +16,8 @@ PKG_RELEASE:=1
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources/
 PKG_MD5SUM:=b569066ac2ba1356c2112b118a7d74d0
-PKG_CAT:=bzcat
-
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 
 include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/kernel.mk
 
 define Package/keynote
   SECTION:=net
@@ -35,15 +32,16 @@ define Package/keynote
   URL:=http://www1.cs.columbia.edu/~angelos/keynote.html
 endef
 
-define Build/Configure
-       $(call Build/Configure/Default, \
-               --enable-static \
-               --enable-shared \
+CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared
+
+define Build/Compile
+       $(call Build/Compile/Default, \
+               LIBS="$(EXTRA_LDFLAGS) -L. -lkeynote -lm -lcrypto" \
        )
 endef
 
-EXTRA_CFLAGS += $(EXTRA_LDFLAGS)
-
 define Build/InstallDev
        mkdir -p $(STAGING_DIR)/usr/include
        $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(STAGING_DIR)/usr/include/